Hell, I'll pay for help at this point!


I've been trying for days to get ZP working. Several people have replied to posts, but the suggestions didn't help.

I'll PayPal an experienced hack some cashola to help me get this implemented. This is pathetic :-)

email chris-at-maltese-dot-net The site that I'm trying to get going is http://photo.maltese.net . I hope to be able to someday integrate it into my blog at http://blog.maltese.net

Hope someone can help out, as I have never had so much trouble with PHP before.



  • sure ..what do you need help in..its open source mate..no payment required to help from me..shoot the problem mate. :)
  • sure ..what do you need help in..its open source mate..no payment required to help from me. but credit me on your site :) .shoot the problem mate. :)
  • Heck yeah, I'll give you the credits. Thank you janantha.

    Here's the issue: I installed the package on my server (unix, I believe). Chmodded everything in the directory to 777. I edited the htaccess to place my absolute path in it... and nothing happens. I keep getting an internal server error.

    What is the best way for you to assist me and what files do you need? I am hosted on PowWeb.

  • First thing i see is..you have a subdomain called http://photo.maltese.net
    when you type that and press return on the browser.your server will only send a reply if it has an index.html or and index.php.

    Secondly you will have a peace of mind if you include your zenphoto installation in the same domain you have your blog..

    also let me know the htaccess code you have used so far
  • OK... I checked the Photo directory and it has an index.php file. Here is the code used in htaccess which also resides in the Photo directory:

    # htaccess file for zenphoto
    # NOTE: Change the RewriteBase below to the absolute path to your zenphoto directory.

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # !!! Change this to the absolute path !!!
    RewriteBase /www/m/maltesenet/photo

    RewriteRule ^zen/(.*)$ - [L]
    RewriteRule ^tests/(.*)$ - [L]
    RewriteRule ^admin$ admin/ [R]
    RewriteRule ^admin/?$ zen/admin.php [R,L]
    RewriteRule ^admin/admin.css$ zen/admin.css [R,L]
    RewriteRule ^admin/admin.js$ zen/admin.js [R,L]

    RewriteRule ^page/([0-9]+)/?$ index.php?page=$1 [QSA,L]
    RewriteRule ^([^/\.]+)/?$ index.php?album=$1 [QSA,L]
    RewriteRule ^([^/\.]+)/page/([0-9]+)/?$ index.php?album=$1&page=$2 [QSA,L]
    RewriteRule ^([^/\.]+)/image/(thumb|[0-9]{1,4})/([^/\\]+)$ zen/i.php?a=$1&i=$3&s=$2 [QSA,L]
    RewriteRule ^([^/\.]+)/image/([^/\\]+)$ albums/$1/$2
    RewriteRule ^([^/\.]+)/([^/\\]+)$ index.php?album=$1&image=$2 [QSA,L]


  • ok..its your absolute path that makes the error. try this /m/maltesenet/photo
    and let me know if its working
  • No good. The change didn't help.
  • have u tried directly accesing the setup file..using the browser..else the only possible paths are these two


    Also try putting this line of code at the top
    DirectoryIndex index.php
    before you append this code check on that absolute path thing ive mentioned..believe me it took me a while to make it work..have paitence..ill help you out..
    Im also thinking if your subdomain is giong to be a factor for this problem..let me think through.meanwhile try the stuff ive mentioned.Also let me know where exactly your planting the htacess file!!!
  • Hey Janantha,

    Both paths didn't work. I also placed the line of code at the top of the htaccess file and tried various combinations of the paths. NG.

    The htaccess file is located in the root of the photo directory.

    No problem with the patience part. This is all a good challenge and learning experience. I thank *you* for your patience and tutelage.

  • then ruling out that left me on thinking about subdomains... so tell me which one is the "primary domain" , if you can send me a screen dump of your root i will be able to understand the directory structure.. in my hosting company to make subdomain..all i have to do is make a subfolder in the root of the account and name it what ever i want and then place an index file on it..i want to know what your one is.. please use my email address janantha@janantha.net to send the screen shot of it. im off to sleep now..will reply you tomorrow..nights
  • Will do, Janantha. I think that I have made some progress. Sadly, I have been chasing my (and forcing you too) tail. There is a HTDOCS subdirectory where anything that is visible to the web must go. Now I can see something, although it appears misconfigured. I'll email you the file.

  • Yes chris..htdocs means apache's root DIR where the files that should be seen by public should go.to make a start try uploading a normal index.html file..and nothing else on to the folder..and then browse and see whether you can see the contents of the index file! .No problemo mate..always glad to help and meet up with challenges! thats my passion. Through trial and error people learn and the things they learn from that will stay in the brain forever. ;) So someday you can help someone else with your knowledge!
  • trisweb Administrator
    Zenphoto currently has problems being at the root of a site. Try putting it in a subdirectory (like /photos) and changing the RewriteBase to /photos (for that example). Should work.
  • I'm having the same issue.

    I have Zenphoto 0.9 running fine in a different directory and created another directory in which to install and test out 1.0beta before committing to the upgrade.

    I can connect to /zentest/admin just fine and do all the admin tasks, so mod_rewrite seems to be working as is most of the application.

    The problem is with rendering the gallery pages. I have tried changing themes and using one I had created for 0.9. All with the same result - a page with no formatting and no working links.

    I'm running this locally on Apache 2 with MySQL 4.1.12.
  • Solved:

    The config.php.example from the 1.0b distribution doesn't contain the

    if (basename($_SERVER['SCRIPT_FILENAME']) == "i.php".....


    Adding this full block to the config.php fixes the install.


    Now I'm looking forward to testing out this new release.
  • So what exactly has to be put into config.php, and where?
    I'm having the same problem as I am trying to run zp directly on a subdomain.
  • Hmm, that's interesting, since we moved that block to functions.php, and changed it a little. Clearly it works for most cases. Obviously, subdomains and pathing in general is an area we can improve greatly.
  • trisweb Administrator
    Yep, we'll get it working better before the final release. For now though, if that works then go for it.

    The full fix is here:
  • The fix for me was to replace the end of the config.php file with this (from the 0.9 distribution).

    /** Do not edit below this line. **/

    $_zp_conf_vars = $conf;

    if (basename($_SERVER['SCRIPT_FILENAME']) == "i.php" || basename($_SERVER['SCRIPT_FILENAME']) == "admin.php") {
    define('SERVERPATH', dirname(dirname($_SERVER['SCRIPT_FILENAME'])));
    define('WEBPATH', dirname(dirname($_SERVER['SCRIPT_NAME'])));
    } else {
    define('SERVERPATH', dirname($_SERVER['SCRIPT_FILENAME']));
    define('WEBPATH', dirname($_SERVER['SCRIPT_NAME']));
    define('SERVERCACHE', SERVERPATH . "/cache");
    define('WEBCACHE', WEBPATH . "/cache");

Sign In or Register to comment.