I have two additional infos:
1. I've been able to read the /zp-data/debug.log (by using extplorer, a php file manager). This is what I found:
{Tue, 31 Jul 2012 15:43:02 GMT}
Backtrace: USER ERROR: MySql Error: ( [i]INSERT INTO `[prefix]options` (`name`,`ownerid`,`theme`,`value`) VALUES ('magick_font_size',0,"",'18') ON DUPLICATE KEY UPDATE `value`='18'[/i] ) failed. MySql returned the error [i]Table 'loeuvrette.collections_options' doesn't exist[/i] in /var/www/htdocs/loeuvrette/public/collections/zp-core/functions-db-MySQL.php on line 59
trigger_error called
from query (functions-db-MySQL.php [59])
from setOption (functions-basic.php [361])
from lib_Imagick_Options->__construct (lib-Imagick.php [45])
from require_once (lib-Imagick.php [26])
from require_once (functions-basic.php [182])
from require_once (functions.php [18])
from require_once (admin-functions.php [9])
from setup.php [247]
2. I have found a file named php_error.log (at /var/log of the shared hosting server), with a couple of times this message (not sure this is related):
[31-Jul-2012 18:09:02] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mhash.so' - /usr/lib/php5/20090626/mhash.so: cannot open shared object file: No such file or directory in Unknown on line 0
[31-Jul-2012 18:09:02] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/xapian.so' - /usr/lib/php5/20090626/xapian.so: cannot open shared object file: No such file or directory in Unknown on line 0
Does any of this help?