Many servers apply a security rule that Web applications may not run from a folder with unsecure file/folder permissions. So, for instance, in the Unix world they may prohibit runnign from a folder that grants access to the "public".
The specific requirments will depend on the server/security configuration. Generally you would like your file/folder permissions to be as secure as possible. But the rub is what is "possible" also depends on the server configuration.
We have seen servers that require the permissions grand access to the "public" or the Zenphoto application will fail.
Symptoms of file/folder permissions are the "permissions" error you got, but they may also show up as "500" errors.