http 500 errors will never be caught and reported by Zenphoto, so the only place you can find out the cause would be in your server error log.
These errors are caused by such thing as file permissions and "mod_security" error traps. For the latter see this thread: http://www.zenphoto.org/support/topic.php?id=36756