You need to check your server error logs as for sure there must be an error occurring. The link above is simply the link for the restore.
Possible causes:
A server timeout (Zenphoto tries to extend the script execution time, but some hosts do not allow this.)
A file/folder permissions issue (not likely if the backup did work, but you never know with some server configurations.)
A problem with the database.
But without the specific error message we are just guessing.