FYI - according to the host support team there are 2 issues.
"Currently, PHP 8.4 is set up for your website. I'm glad to inform you that our engineers identified the file /public_html/zp-data/.mutex/zP is causing the 503 Service Unavailable error."
But I don't know what the cause of this could be. The file also gets recreated when accessing the admin panel. But working for now.
Secondly they said this
"Further, our engineers found that the following extensions have been enabled in the php.ini file, and these extensions, when added to php.ini, make the website not work properly. So I have now removed these extensions.
extension=propro.so
extension=raphf.so
extension=ctype.so"
I don't know exactly what "not work properly" means and the impact of removing those extensions but let's try adding some photos ...