Okay, here's what I've figured out so far.
It seems like the error is being caused by the WordPress is_404 function. Whenever I try to use that function on an included zenphoto page, it returns as True. Pretty permalinks are also tied into that function in parts, so I'm guessing that's why by turning them off, the pages don't give the silent 404 error.
So going with that information, I've managed to figure out two possible solutions.
#1. Editing the is_404 function. I've really got no experience messing with WP core files, so I really didn't want to do this. Here are two links that I've found about the problem.
http://ddhr.org/2005/11/29/wordpress-functions/
http://andy.wordpress.com/2006/08/13/useless-code-in-wordpress-themes/
#2. The easiest "solution" is just to add:
`header("HTTP/1.1 200 OK");
header("Status: 200 OK");`
[i]above[/i] wherever it is you're calling WordPress' get_header(); function in your zenphoto template.
http://wordpress.org/support/topic/84233?replies=2