Here is a quick summary of your errors:
1. this is a warning. You can ignore it if you wish although it would be best to disab le the options in PHP>
2.also a warning. This is not a problem for English speaking installations. Unless you want accented characters you can ignore this.
3. this is another warning. Some servers will not work with strict permissions, so until everything else is resolved, leave this alone.
4. This is a little more of a problem. When setup runs it attempts to create only new tables. If your MySQL will not tell Zenphoto what tables exist, the only option is to try to create them. This may also be related to the `sql` errors. If those tables already exist, then you can ignore the error. If not, it is unlikely that things can be made to work correctly. You could create the tables manually--their definitions are in setup.php. If you do that, be sure to run setup afterwards since the definsions are not updated when the tables change. Instead, the tables are modified later on in the process.
NB: I do not know what table `#sql-1a1c_1793` would be. It is not something Zenphoto tries to create.
#5. You have probably not copied the .htaccess file that came with the Zenphoto install. Probably not an issue since there is a revision check to be sure that the .htaccess version matches what is expected by Zenphoto.