Member
Member
PsyDuck   2006-06-01, 18:49
#1
Hi!

Just installed zenphoto 1.0.3 and all went well except for a small glitch.....I can't see the photos?

I get this error in the apache error_log:
File does not exist: "/srv/www/htdocs/zenphoto/maja, referer: <Myserver>/zenphoto/"

the folder maja is located under "/srv/www/htdocs/zenphoto/albums/maja"

Any ideas?
Member
Member
PsyDuck   2006-06-01, 19:30
#2
Just discovered that rewrite wasn't enabled on my server!

Still didn't work with rewrite after I enabled it though. :-(
Member
Member
Chilifrei64   2006-06-01, 21:18
#3
do you have a link to the gallery so we can better troubleshoot the problem?
Member
Member
PsyDuck   2006-06-02, 08:13
#4
Here's the link

http://claesson.homeip.net/zenphoto/

Works great with rewrite turned off.
Member
Member
PsyDuck   2006-06-02, 08:41
#5
Finally found the error!!

Had to change the apache configuration.
Member
Member
FatalCure   2006-06-02, 14:53
#6
PsyDuck - Can you explain how, I have the same problem - .htaccess looks setup correctly

LoadModule rewrite_module modules/mod_rewrite.so in \xampp\apache\conf\httpd.conf

has the # removed.

Gallery works fine if modrewrite is set to false but when set to true no images display, however with the stopdesign theme if I view it the gallery with rewrite off and the images get cached then when I turn it on they display, but links to albums don't.

http://fatalcure.org/Photos/

Thanks in advaced.

Dave.
Member
Member
PsyDuck   2006-06-02, 19:21
#7
As far as I understood it you have to enable symlinks for the Directory in order to get mod_rewrite to work
I added
"Options FollowSymLinks"
to my Directory configuration.
Make sure that you don't have any
"AllowOverride None" set somewhere for that Directory.
Member
Member
FatalCure   2006-06-02, 22:06
#8
Hmm seems to half work..

Added:

<Directory "E:\Server\xampp\htdocs\Photos">
Options Indexes FollowSymLinks
</Directory>

Now, http://www.fatalcure.org/photos/ comes up with:

Zenphoto error: Album does not exist.

However, links to my galleries now work, ie http://www.fatalcure.org/photos/rave
http://www.fatalcure.org/photos/sandsculptures

Any ideas?
Member
Member
FatalCure   2006-06-03, 06:42
#9
I'm also getting this in the error logs:

[Sat Jun 03 08:05:24 2006] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

[Sat Jun 03 08:05:24 2006] [warn] RewriteCond: NoCase option for non-regex pattern '-d' is not supported and will be ignored.
Member
Member
FatalCure   2006-06-03, 11:13
#10
Ok, just realised that

http://www.fatalcure.org/photos/index.php

actually works, but /photos comes up with that
Zenphoto error: Album does not exist.
error,
Member
Member
FatalCure   2006-06-03, 11:27
#11
Ok, something else that might help, damn I am making alot of posts in this thread, previous version still works

http://fatalcure.org/gallery/

but since the upgrade it comes up with the error I mentioned above, I might just stick with the previous version for now.
Developer
Developer
trisweb   2006-06-03, 18:24
#12
Or turn off mod_rewrite -- it seems like your mod_rewrite version may be bad because of those log errors.
Member
Member
FatalCure   2006-06-04, 06:26
#13
Can I upgrade the mod_rewrite modules from somewhere?
Member
Member
PsyDuck   2006-06-04, 09:34
#14
What version of apache are you running?
Member
Member
FatalCure   2006-06-04, 11:52
#15
Apache 2.2.0
Member
Member
pipedarkfire   2006-06-22, 06:23
#16
I had the same error

Zenphoto error: Album does not exist.

using xampp and noticed that the url was being rewritten to

Quote:index.php?album=index.php
which is probably a configuration problem somewhere and the quick fix for me was to just do this:
`

# new fix for index.php passed as a param

RewriteRule index\.php$ index.php [L,QSA]

# put above this line

RewriteRule ^([^/]+)/?$ index.php?album=$1 [L,QSA]

`

If anyone knows where the root problem of this might be I would appreciate it but for now I hope this helps others. I imagine it's one of the settings from the httpd.conf.
Member
Member
FatalCure   2006-06-22, 06:42
#17
Yep, that fix worked for me too, thanks for the email Alex.
Junior Member
Junior Member
unmake   2006-09-21, 23:37
#18
thanks [b]pipedarkfire[/b] - fixed my install.
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.