It turns out that since my account was opened several years ago that it was an older version of PHP. So that problem is now solved.
However, the GoDaddy rep I spoke to had no idea what Magic Quote was. Your instructions about disabling it don't help me since I can't even find a file called .ini I have no idea what this is :p
I tried modifying the .htaccess file, but that didn't do anything.
A new error has come up about mbstring, whatever that is.
Also, I'm now getting an error that it can't connect to the MySQL database. I filled in the correct info, but it still shows an error.
http://www.justeyecandy.com/zenphoto3/zp-core/setup.php
Why is this so difficult? I've recently added WordPress and Joomla with no problems So I'm not a complete idiot :p