sitemap not working

I just upgraded the latest version zenphoto and when I try to run
"SITEMAP TOOLS" it shows gray page returned no error.

need help on resolving this.

Tags:

Comments

  • acrylian Administrator

    Please review your PHP error log and/or the Zenphoto debug log. I just had tried the sitemap a few days ago and it worked.

  • wildart Member

    i just cleared log and ran sitemap but in debug its nothing..

  • acrylian Administrator

    Anything in the PHP server log? That is often more accurate than Zenphoto's debug log.

  • wildart Member

    shared server dont know how to get php log in cpanel

  • acrylian Administrator
    edited July 15

    Ask your host. It probably must be enabled or is somewhere hidden. Otherwise I cannot really help as I would have to guess around.

    But you can also try the support build from GitHub.

  • wildart Member

    u mean download newversion manually and install?

  • acrylian Administrator

    Basically, download and install the support build (= master from GitHuB = 1.5.1beta).

  • wildart Member

    have got it enabled php log and log shows no activity not SITEMAP TOols running returns any error.

    if you want I can give you access in personal to see.

  • acrylian Administrator
    edited July 16

    Normally we don't do this but please mail me.

  • wildart Member

    Thank You so much. Where can I send you email with credential ?

  • acrylian Administrator

    You already mailed me recently because of your login problems, didn't you? ;-)

  • wildart Member
    edited July 16

    yes i posted u pm

  • wildart Member

    I just clean installed zenphoto latest and the sitemap-extended Plugin behaved same like above. Seem the functionality with 1.5 is broken somewhere of the plugin.

  • acrylian Administrator

    It is not broken since I cannot reproduce any problem. It works on test sites and on our own site which is a fairly standard server, too.

    I am sorry unless you can provide any error or any clue to reproduce I cannot help.

  • wildart Member

    i havecompletely re imstalled new version on new url via cpanel softaculous and that did the same thing. yet i shall try again installing via xampp on local host may be that could change things and i shsll revert for the same.

  • acrylian Administrator
    edited July 17

    Try to install without cpanel softaculous as these installer scripts sometimes cause trouble (although that should not involve this specific plugin).

  • wildart Member

    i juwt manual uoloaded 1.5 over write and it worked. seems softaculous has an issue through cpanel.

    thanks for ur support.

  • acrylian Administrator

    Thanks for the feedback!

  • I have been experiencing the same problem with Sitemaps not being generated (Get Grey Screen). Including ZPMobile Menu items not Loading but Zenpage OK. Since upgrade July 11.
    ......I also used Softaculous to upgrade.
    Took your advice above and re-installed manually.
    ZPMobile now works fine but still having probs with Sitemaps -
    Error Log: [02-Aug-2018 22:04:22 Europe/London] PHP Fatal error: Call to undefined function sitemap::passAlbums() in /home/hughboyle/public_html/zp-core/zp-extensions/sitemap-extended.php on line 484

    Also when running setup, get the following warning:
    PHP gettext() support [is not present]

  • ZPMobile Menu items not Loading when plugin "Social Sharing" activated and "all" selected.
    Possible Bug-
    When Plugin enabled with "all" checked: No menu items load.
    When Plugin enabled with "Whatsapp" unchecked and all other socials checked: OK and working fine.

  • acrylian Administrator

    Please one issue/topic per forum topic. ZPmobile has nothing to do with sitemaps. Please open another topic for that.

    Regarding the sitemap please try the support build from GitHub where this general issue should be fixed.

Sign In or Register to comment.