The new plugin has not been recognized

habe Member

Hello, I added a new plugin, swipe_gestures, to the plugin directory but it ha not been recognized. What I am doing wrong?

Comments

  • acrylian Administrator, Developer
    edited August 11

    From the plugin readme:

    Put the file swipe_gestures.php and the folder of the same name into your /plugins folder and enable the plugin.

    I guess you just accidentally put the whole folder of the extracte repo itself into the plugins folder. That will not work.

    If that isn't it, please review all debug logs.

  • habe Member

    Thanks for the answer, indeed I made the mistake you mentioned. Now the plugin is listed and I activated the "Single image page" swipe, but I cannot swipe, am I still, again, making a mistake?

  • acrylian Administrator, Developer

    DId you set the options?

  • habe Member

    Yes, "Single image page"

  • acrylian Administrator, Developer

    Then pelase review the debug and also your browser console log. Perhaps you have some JS error somewhere.

    Which theme are you using?

  • habe Member

    The theme is zpmobile. Neither in the debug file or in the browser I can find a relating error.

  • acrylian Administrator, Developer
    edited August 11

    Okay,that's the problem. That plugin does not work with zpMobile. zpMobile is very specific using the jquery mobile JS framework which collides with other JS heavily as it takes over everything basically.

  • habe Member

    Thanks for your help.
    What a pitty.
    I choose this theme because it is, for me, a good design for smartphone and tablets. what other

  • habe Member

    (sorry) theme would you advise.

  • acrylian Administrator, Developer
    edited August 11

    I can't advise, there are a few responsive themes:
    https://www.zenphoto.org/page/search/tags/responsive/

Sign In or Register to comment.